What’s Vulnerable › Vulnerabilities
CVE-2026-64174: wifi: cfg80211: advance loop vars in cfg80211_merge_profile()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-08-13
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: cfg80211: advance loop vars in cfg80211_merge_profile() cfg80211_merge_profile() reassembles a Multi-BSSID non-transmitted BSS profile that has been split across multiple consecutive MBSSID elements. Its while-loop calls cfg80211_get_profile_continuation(ie, ielen, mbssid_elem, sub_elem) but never advances mbssid_elem or sub_elem inside the body. Each iteration therefore searches for a continuation that follows the same fixed pair; the helper returns the same next_mbssid; and the same next_sub bytes are memcpy()'d into merged_ie at a growing offset until the buffer fills. Advance both mbssid_elem and sub_elem to the just-consumed continuation so the next call to cfg80211_get_profile_continuation() searches for a further continuation beyond it (or returns NULL when none exists). A specially-crafted malicious beacon can take advantage of this bug to cause the kernel to spend an excessive amount of time in cfg80211_merge_profile (up to as much as 2ms per beacon received), which could theoretically be abused in some way.
Affected products
- Linux kernel: from 5.2 before 5.10.258; from 5.11 before 5.15.209; from 5.16 before 6.1.175; from 6.2 before 6.6.142; from 6.7 before 6.12.92; from 6.13 before 6.18.34 — fixed in 5.10.258, 5.15.209, 6.1.175, 6.12.92, 6.18.34, 6.6.142
How to fix
Upgrade to a fixed version: Linux kernel 5.10.258, 5.15.209, 6.1.175, 6.12.92. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1343a480f84b80c1249133a90ef87f8751d65cbb
- https://git.kernel.org/stable/c/1ced0f5a851f9cae274545a42a06c459b7fd8881
- https://git.kernel.org/stable/c/5817e1e5205498a5df66eba2b34e817f4210fd0f
- https://git.kernel.org/stable/c/67915715fd3874057457363c87c63e18829527df
- https://git.kernel.org/stable/c/6cfae4914439878b8acb35c7e3b40096eeb2ad9c
- https://git.kernel.org/stable/c/7666dbb1bacc4ba522b96740cba7283d243d16e1
- https://git.kernel.org/stable/c/c0bc4c8bd556cbe036a5b9ed333c0aab9aadfcb8
- https://git.kernel.org/stable/c/cedbb608494ba1e7a5c6c56b7f1d3fd470094f28
Get alerted when CVE-2026-64174 or the next vulnerability affects your stack