What’s Vulnerable › Vulnerabilities
CVE-2026-64176: wifi: iwlwifi: mvm: fix driver-set TX rates on old devices
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-19
- Weakness: CWE-682
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: mvm: fix driver-set TX rates on old devices On old devices such as 7265D, rates are still encoded in version 1 format, which doesn't use the CCK/OFDM rate index (0-3/0-7) but rather their PLCP value (e.g. 10 for 1 Mbps CCK rate.) While introducing v3 rates, I changed the driver from internally handling v1 rates and converting to v2, to internally handling v3 and converting to v1 or v2 according to the firmware. I accordingly changed the code in iwl_mvm_mac80211_idx_to_hwrate() to no longer have different values for different APIs. This was correct. However, I later reverted this part of the change, because it was reported that I had broken beacon rates, causing a FW assert/crash. This caused TX_CMD rates to be set incorrectly, potentially causing a warning when reported back from the device as having been used. Fix this (hopefully correctly now) by handling beacon rates in the TX_CMD that's embedded in the beacon template command separately. Restore iwl_mvm_mac80211_idx_to_hwrate() to return only the rate index, not PLCP value, fixing the real TX_CMD.
Affected products
- Linux kernel: from 6.17.9 before 6.18; from 6.18.1 before 6.18.34; from 6.19 before 7.0.11; 6.18, 6.18-rc6, 6.18-rc7, 7.1-rc1, 7.1-rc2, 7.1-rc3 (+1) — fixed in 6.18, 6.18.34, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.18, 6.18.34, 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6b58a79f2cd98156856eb49e8b55db5facdd7e6d
- https://git.kernel.org/stable/c/6fe92651b44fd3cfc8dcfdaad0e82885c384dada
- https://git.kernel.org/stable/c/fb84b5cbcaab3ca0f4e961d92a40ed7f3aac483b
Get alerted when CVE-2026-64176 or the next vulnerability affects your stack