What’s Vulnerable › Vulnerabilities
CVE-2026-64208: crypto/krb5, rxrpc: Fix lack of pre-decrypt/pre-verify length checks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-08-12
Description
In the Linux kernel, the following vulnerability has been resolved: crypto/krb5, rxrpc: Fix lack of pre-decrypt/pre-verify length checks Change the krb5 crypto library to provide facilities to precheck the length of the message about to be decrypted or verified. Fix AF_RXRPC to make use of this to validate DATA packets secured with RxGK.
Affected products
- Linux kernel: from 6.16 before 6.18.34; from 6.19 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 6.18.34, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.18.34, 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2b50aceafe6606ea52ed42aadd1b4d44a188aade
- https://git.kernel.org/stable/c/585f9f6aef5c4542ac9d6ec45cd7dbc7df9af3ff
- https://git.kernel.org/stable/c/9217017f4bce53dddb8d547837f1f707045d64ad
Get alerted when CVE-2026-64208 or the next vulnerability affects your stack