What’s Vulnerable › Vulnerabilities
CVE-2026-64217: netfs: Fix overrun check in netfs_extract_user_iter()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-08-11
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: netfs: Fix overrun check in netfs_extract_user_iter() Fix netfs_extract_user_iter() so that if iov_iter_extract_pages() overfills pages[], then those pages don't get included in the iterator constructed at the end of the function. If there was an overfill, memory corruption has already happened.
Affected products
- Linux kernel: from 6.3 before 6.6.142; from 6.7 before 6.12.92; from 6.13 before 6.18.34; from 6.19 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 6.12.92, 6.18.34, 6.6.142, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.12.92, 6.18.34, 6.6.142, 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00efe58bbdcc93272d579ca24bfc912563f4a204
- https://git.kernel.org/stable/c/0ef37eef83fad3542ee06db2940433ae1a92b39d
- https://git.kernel.org/stable/c/96cc3beb2390ba9f9c128c5733c0ccfe450dd4f9
- https://git.kernel.org/stable/c/afeb32d9bf9aaeea51d0f723a19f14afb73bd94d
- https://git.kernel.org/stable/c/f48b9157f0f611fa436c360648603d5ded719b12
Get alerted when CVE-2026-64217 or the next vulnerability affects your stack