What’s Vulnerable › Vulnerabilities
CVE-2026-64231: drm/msm/dsi: don't dump registers past the mapped region
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-08-12
Description
In the Linux kernel, the following vulnerability has been resolved: drm/msm/dsi: don't dump registers past the mapped region On DSI 6G platforms the IO address space is internally adjusted by io_offset. Later this adjusted address might be used for memory dumping. However the size that is used for memory dumping isn't adjusted to account for the io_offset, leading to the potential access to the unmapped region. Lower ctrl_size by the io_offset value to prevent access past the mapped area. msm_disp_snapshot_add_block+0x1d4/0x3c8 [msm] (P) msm_dsi_host_snapshot+0x4c/0x78 [msm] msm_dsi_snapshot+0x28/0x50 [msm] msm_disp_snapshot_capture_state+0x74/0x140 [msm] msm_disp_snapshot_state_sync+0x60/0x90 [msm] _msm_disp_snapshot_work+0x30/0x90 [msm] kthread_worker_fn+0xdc/0x460 kthread+0x120/0x140 Patchwork: https://patchwork.freedesktop.org/patch/721747/
Affected products
- Linux kernel: from 5.14 before 6.1.175; from 6.2 before 6.6.142; from 6.7 before 6.12.92; from 6.13 before 6.18.34; from 6.19 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 6.1.175, 6.12.92, 6.18.34, 6.6.142, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.1.175, 6.12.92, 6.18.34, 6.6.142. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/567b5e976e2e15280d78c9ef2add1954a0bbb5b1
- https://git.kernel.org/stable/c/5b49a46baa853b26dbefa65c6c75dd9ff69f63d4
- https://git.kernel.org/stable/c/5e2c196c3430fb94225c4102b1028d0146544761
- https://git.kernel.org/stable/c/9f8274749d9010a1a72f97e547b7eb9ebb82345b
- https://git.kernel.org/stable/c/a184aec790135938b0fadb415e55accd1f8685a0
- https://git.kernel.org/stable/c/ab871d5882953e5574ae2bc47bec88c2e3d22663
Get alerted when CVE-2026-64231 or the next vulnerability affects your stack