What’s Vulnerable › Vulnerabilities
CVE-2026-64254: NTB: epf: Avoid pci_iounmap() with offset when PEER_SPAD and CONFIG share BAR
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-08-17
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: NTB: epf: Avoid pci_iounmap() with offset when PEER_SPAD and CONFIG share BAR When BAR_PEER_SPAD and BAR_CONFIG share one PCI BAR, the module teardown path ends up calling pci_iounmap() on the same iomem with some offset, which is unnecessary and triggers a kernel warning like the following: Trying to vunmap() nonexistent vm area (0000000069a5ffe8) WARNING: mm/vmalloc.c:3470 at vunmap+0x58/0x68, CPU#5: modprobe/2937 [...] Call trace: vunmap+0x58/0x68 (P) iounmap+0x34/0x48 pci_iounmap+0x2c/0x40 ntb_epf_pci_remove+0x44/0x80 [ntb_hw_epf] pci_device_remove+0x48/0xf8 device_remove+0x50/0x88 device_release_driver_internal+0x1c8/0x228 driver_detach+0x50/0xb0 bus_remove_driver+0x74/0x100 driver_unregister+0x34/0x68 pci_unregister_driver+0x34/0xa0 ntb_epf_pci_driver_exit+0x14/0xfe0 [ntb_hw_epf] [...] Fix it by unmapping only when PEER_SPAD and CONFIG use difference bars.
Affected products
- Linux kernel: from 6.0 before 6.1.177; from 6.2 before 6.6.144; from 6.7 before 6.12.95; from 6.13 before 6.18.38; from 6.19 before 7.1.3 — fixed in 6.1.177, 6.12.95, 6.18.38, 6.6.144, 7.1.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.177, 6.12.95, 6.18.38, 6.6.144. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06f6dd2ff2bd07eaf7178a807407ff27e85122b4
- https://git.kernel.org/stable/c/81371dbd23601f67f01372817fdbab42c5601e43
- https://git.kernel.org/stable/c/9764a786ba98db58f0725913c369e721253aba33
- https://git.kernel.org/stable/c/a4be4a1308f02bff79a30eea2d04ead5b63685f2
- https://git.kernel.org/stable/c/d876153680e3d721d385e554def919bce3d18c74
- https://git.kernel.org/stable/c/eb47b9bffd07a47b84910847cb5ea066ce184055
Get alerted when CVE-2026-64254 or the next vulnerability affects your stack