What’s Vulnerable › Vulnerabilities
CVE-2026-64291: iommufd: Set veventq_depth upper bound
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-25 · updated 2026-08-17
Description
In the Linux kernel, the following vulnerability has been resolved: iommufd: Set veventq_depth upper bound iommufd_veventq_alloc() accepts any !0 veventq_depth from userspace, with an upper bound at U32_MAX. This leaves a vulnerability where userspace can allocate excessively large queues to exhaust kernel memory reserves. Cap the veventq_depth (maximum number of entries) to 1 << 19, matching the maximum number of entries in the SMMUv3 EVTQ (the largest use case today).
Affected products
- Linux kernel: from 6.15 before 6.18.39; from 6.19 before 7.1.4 — fixed in 6.18.39, 7.1.4
How to fix
Upgrade to a fixed version: Linux kernel 6.18.39, 7.1.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6ebf2eb46fbd5b40393ff8fbb847ba96925beaff
- https://git.kernel.org/stable/c/e7b5e55652746b1221b9c10ff80eae8a154101ba
- https://git.kernel.org/stable/c/f565297edf316016be4a1a9e2eb9f39359313f43
Get alerted when CVE-2026-64291 or the next vulnerability affects your stack