What’s Vulnerable › Vulnerabilities
CVE-2026-6437: AWS EFS CSI Driver Mount Option Injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-17 · updated 2026-10-26
- Weakness: CWE-88
Description
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Affected products
- Amazon AWS EFS CSI Driver: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: Amazon AWS EFS CSI Driver 3.0.1. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-016-aws/
- https://github.com/kubernetes-sigs/aws-efs-csi-driver/releases/tag/v3.0.1
- https://github.com/kubernetes-sigs/aws-efs-csi-driver/security/advisories/GHSA-mph4-q2vm-w2pw
Get alerted when CVE-2026-6437 or the next vulnerability affects your stack