What’s Vulnerable › Vulnerabilities
CVE-2026-64606: Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-502
Description
Deserialization of untrusted data vulnerability that may allow class-registration checks to be bypassed during Java lambda deserialization. Only lambda capture class is affected This issue affects Apache Fory: from before 1.4.0. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Fory: from 0.5.0 before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fory 1.4.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/py6fbvm9nk1gxdd85rbzbozwzfh0jrsc
- http://www.openwall.com/lists/oss-security/2026/07/21/4
Get alerted when CVE-2026-64606 or the next vulnerability affects your stack