What’s Vulnerable › Vulnerabilities
CVE-2026-64627: Parse Server 9.0.0 Schema Disclosure via GraphQL Variable Coercion
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-209
Description
Parse Server versions >= 9.0.0 before 9.10.0-alpha.4 and versions before 8.6.85 contain a schema disclosure vulnerability. When the GraphQL API is mounted with public introspection disabled (graphQLPublicIntrospection: false, the default), schema-derived 'Did you mean ...?' suggestions were still returned in GraphQL error messages produced during variable coercion, which were not covered by the introspection-hardening control (that only handled validation errors). An unauthenticated caller possessing only the public application id can iteratively recover hidden schema identifiers — including registered Cloud Code function names and Parse class and field names — by submitting queries or mutations whose variables contain near-miss enum values or input-object field names. This is a follow-up bypass of GHSA-8cph-rgr4-g5vj. The issue is fixed in 9.10.0-alpha.4 and 8.6.85.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.0-alpha.4; before 8.6.85 — fixed in 8.6.85, 9.10.0-alpha.4
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.85, 9.10.0-alpha.4. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9g8f-h8f3-hjcm
- https://www.vulncheck.com/advisories/parse-server-schema-disclosure-via-graphql-variable-coercion
Get alerted when CVE-2026-64627 or the next vulnerability affects your stack