What’s Vulnerable › Vulnerabilities
CVE-2026-64641: Next.js: Denial of Service in App Router using Server Actions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-10-24
- Weakness: CWE-834
Description
Next.js is a React framework for building full-stack web applications. In versions 13.0.0 through 15.5.20 and 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive CPU usage blocking processing of further requests in the same process. This issue has been fixed in versions 15.5.21 and 16.2.11.
Affected products
- Next.js: from 13.0.0 before 15.5.21; from 16.0.0 before 16.2.11 — fixed in 15.5.21, 16.2.11
- Npm Next: from 13.0.0 before 15.5.21; from 16.0.0 before 16.2.11 — fixed in 15.5.21, 16.2.11
How to fix
Upgrade to a fixed version: Next.js 15.5.21, 16.2.11; Npm Next 15.5.21, 16.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/019628571641dec57aaf349ba0c360e3964e6f12
- https://github.com/vercel/next.js/pull/96013
- https://github.com/vercel/next.js/releases/tag/v15.5.21
- https://github.com/vercel/next.js/releases/tag/v16.2.11
- https://github.com/vercel/next.js/security/advisories/GHSA-m99w-x7hq-7vfj
Get alerted when CVE-2026-64641 or the next vulnerability affects your stack