What’s Vulnerable › Vulnerabilities
CVE-2026-64642: Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-10-24
- Weakness: CWE-285
Description
Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.
Affected products
- Next.js: from 16.0.0 before 16.2.11 — fixed in 16.2.11
How to fix
Upgrade to a fixed version: Next.js 16.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/6bf4df14508ad6c0cd46af50c6051ee42f2d9151
- https://github.com/vercel/next.js/pull/96014
- https://github.com/vercel/next.js/releases/tag/v16.2.11
- https://github.com/vercel/next.js/security/advisories/GHSA-6gpp-xcg3-4w24
Get alerted when CVE-2026-64642 or the next vulnerability affects your stack