What’s Vulnerable › Vulnerabilities
CVE-2026-64644: Next.js: Denial of Service in the Image Optimization API using SVGs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-10-24
- Weakness: CWE-407
Description
Next.js is a React framework for building full-stack web applications. In versions 15.5.0 through 15.5.20 and 16.0.0 through 16.2.10, when self-hosting Next.js with the default image loader, the Image Optimization API can optimize remotely hosted images if configured (not enabled by default). If those images contain malicious content, they can cause CPU exhaustion in /_next/image endpoints.Only config.images.remotePatterns is affected, and just the patterns in that array, whereas config.images.unoptimized: true, config.images.loader: 'custom', and Vercel are not impacted. This issue has been fixed in versions 15.5.21 and 16.2.11.
Affected products
- Next.js: from 15.5.0 before 15.5.21; from 16.0.0 before 16.2.11 — fixed in 15.5.21, 16.2.11
How to fix
Upgrade to a fixed version: Next.js 15.5.21, 16.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/93cb90891402fa4c47798d03cb9e05c13233766c
- https://github.com/vercel/next.js/pull/96006
- https://github.com/vercel/next.js/releases/tag/v15.5.21
- https://github.com/vercel/next.js/releases/tag/v16.2.11
- https://github.com/vercel/next.js/security/advisories/GHSA-q8wf-6r8g-63ch
Get alerted when CVE-2026-64644 or the next vulnerability affects your stack