What’s Vulnerable › Vulnerabilities
CVE-2026-64657: Budibase: Database Connector SQL Injections in PostgreSQL, MS SQL, and MySQL
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-09-08
- Weakness: CWE-89
Description
Budibase is an open-source low-code platform. Prior to 3.39.19, the PostgreSQL datasource connector in packages/server/src/integrations/postgres.ts interpolates the user-controlled schema configuration field into a SET search_path statement without escaping embedded double quotes, allowing an authenticated administrator who saves or tests the datasource to execute arbitrary SQL through the simple query protocol. This issue is fixed in version 3.39.19.
Affected products
- budibase: before 3.39.19
References
- https://github.com/Budibase/budibase/commit/67572a82c3850964f388bfd969779dc025a80224
- https://github.com/Budibase/budibase/security/advisories/GHSA-qqf5-x7mj-v43p
- https://github.com/Budibase/budibase/security/advisories/GHSA-qqf5-x7mj-v43p
Get alerted when CVE-2026-64657 or the next vulnerability affects your stack