What’s Vulnerable › Vulnerabilities
CVE-2026-64677: Anki's local HTTP server is vulnerable to directory traversal attacks
- Severity: medium (CVSS 5.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-10-24
- Weakness: CWE-22
Description
Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, endpoints in Anki's local HTTP server do not adequately constrain requested media and built-in data paths, allowing scripts served from shared decks, or malicious websites combined with an origin-check bypass, to read local files through directory traversal. This issue is fixed in version 25.09.3.
Affected products
- Ankitects Anki: from 25.09.3
References
- https://github.com/ankitects/anki/commit/f4692e54a4fafc89528afab1983f0b98d593023f
- https://github.com/ankitects/anki/security/advisories/GHSA-78wr-2gg2-4hqg
Get alerted when CVE-2026-64677 or the next vulnerability affects your stack