What’s Vulnerable › Vulnerabilities
CVE-2026-6472: PostgreSQL CREATE TYPE does not check multirange schema CREATE privilege
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing authorization in PostgreSQL CREATE TYPE allows an object creator to hijack other queries that use search_path to find user-defined types, including extension-defined types. That is to say, the victim will execute arbitrary SQL functions of the attacker's choice. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
Affected products
- PostgreSQL: before 14.23; from 15.0 before 15.18; from 16.0 before 16.14; from 17.0 before 17.10; from 18.0 before 18.4 — fixed in 14.23, 15.18, 16.14, 17.10, 18.4
How to fix
Upgrade to a fixed version: PostgreSQL 14.23, 15.18, 16.14, 17.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6472 or the next vulnerability affects your stack