What’s Vulnerable › Vulnerabilities
CVE-2026-6476: PostgreSQL pg_createsubscriber allows SQL injection via subscription name
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection in PostgreSQL pg_createsubscriber allows an attacker with pg_create_subscription rights to execute arbitrary SQL as a superuser. The attack takes effect when pg_createsubscriber next runs. Within major versions 17 and 18, minor versions before PostgreSQL 18.4 and 17.10 are affected. Versions before PostgreSQL 17 are unaffected.
Affected products
- PostgreSQL: from 17.0 before 17.10; from 18.0 before 18.4 — fixed in 17.10, 18.4
How to fix
Upgrade to a fixed version: PostgreSQL 17.10, 18.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6476 or the next vulnerability affects your stack