What’s Vulnerable › Vulnerabilities
CVE-2026-64851: Grav Shortcode Core Plugin: Stored XSS in shortcode-core attribute handlers
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-09-09
- Weakness: CWE-79
Description
Grav Shortcode Core Plugin allows for the development shortcode plugins that utilize the common format utilized by WordPress and BBCode. Prior to 6.2.2, Grav Shortcode Core passes shortcode syntax through Security::detectXss() because it contains no literal less-than character, then ColorShortcode.php and related attribute handlers concatenate an attacker-controlled parameter into HTML without encoding. An account with admin.pages permission can close the generated attribute and add an event handler, creating stored cross-site scripting that executes for visitors or administrators who view the page. This issue is fixed in version 6.2.2.
Affected products
- getgrav grav-plugin-shortcode-core: before 6.2.2
References
- https://github.com/getgrav/grav-plugin-shortcode-core/commit/2a55eac8a2cc7f6c2d4923ab2fa7991039620597
- https://github.com/getgrav/grav-plugin-shortcode-core/releases/tag/6.2.2
- https://github.com/getgrav/grav/security/advisories/GHSA-q5fw-vpqc-fgph
- https://github.com/getgrav/grav/security/advisories/GHSA-q5fw-vpqc-fgph
Get alerted when CVE-2026-64851 or the next vulnerability affects your stack