What’s Vulnerable › Vulnerabilities
CVE-2026-65008: Grav before 2.0.7 Remote Code Execution via Blueprint dynamicData
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-94
Description
Grav 2.0.4 (fixed in 2.0.7) contains a remote code execution vulnerability in Blueprint::dynamicData() (system/src/Grav/Common/Data/Blueprint.php), which passes a Class::method callable string and its arguments directly to call_user_func_array() without any allowlist. Because the form plugin routes page frontmatter through this path, an authenticated account with the admin.pages (or api.pages.write) permission can plant a malicious callable directive in a page. The command then executes as the web-server user whenever anyone — including an unauthenticated visitor — accesses the page.
Affected products
- getgrav grav: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: getgrav grav 2.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-fj2p-qj2f-74v5
- https://www.vulncheck.com/advisories/grav-before-remote-code-execution-via-blueprint-dynamicdata
- https://github.com/getgrav/grav/security/advisories/GHSA-fj2p-qj2f-74v5
Get alerted when CVE-2026-65008 or the next vulnerability affects your stack