What’s Vulnerable › Vulnerabilities
CVE-2026-65009: OpenRemote before 1.26.2 Information Disclosure via Syslog REST API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-08
- Weakness: CWE-200
Description
OpenRemote versions before 1.26.2 contain an information disclosure vulnerability in the SyslogResource REST endpoint that fails to filter operational logs by realm. Attackers with the read:rules role can access the GET /api/{realm}/syslog/event endpoint to retrieve operational logs from all tenants, exposing asset IDs, agent connection details, rule names, and protocol errors across the multi-tenant deployment.
Affected products
- openremote: before 1.26.2 — fixed in 1.26.2
How to fix
Upgrade to a fixed version: openremote 1.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/openremote/openremote/security/advisories/GHSA-fv8q-rwj8-2c55
- https://www.vulncheck.com/advisories/openremote-before-information-disclosure-via-syslog-rest-api
- https://github.com/openremote/openremote/security/advisories/GHSA-fv8q-rwj8-2c55
Get alerted when CVE-2026-65009 or the next vulnerability affects your stack