What’s Vulnerable › Vulnerabilities
CVE-2026-6515: Insufficient Session Expiration in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-06-17
- Weakness: CWE-613
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that could have allowed a user to use invalidated or incorrectly scoped credentials to access Virtual Registries under certain conditions.
Affected products
- GitLab: from 18.2.0 before 18.9.6; from 18.10.0 before 18.10.4; 18.11.0 — fixed in 18.10.4, 18.9.6
How to fix
Upgrade to a fixed version: GitLab 18.10.4, 18.9.6. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/04/22/patch-release-gitlab-18-11-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/595993
Get alerted when CVE-2026-6515 or the next vulnerability affects your stack