What’s Vulnerable › Vulnerabilities
CVE-2026-65432: Apache CXF: XXE via WSDL/XSD import parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-10-24
- Weakness: CWE-611
Description
Apache CXF reads a top-level WSDL through its hardened StaxUtils path, which disables XML DTDs and external entities. However, any <wsdl:import> or <xsd:import> referenced from that top-level WSDL is handed off to WSDL4J, which does not disable DOCTYPE declarations or external entities. As a result, the protections applied to the top-level document do not extend to imported documents, leaving imported WSDL/XSD content vulnerable to XML External Entity (XXE) attacks. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
Affected products
- Apache Software Foundation Apache CXF: before 3.6.12; from 4.0.0 before 4.1.8; from 4.2.0 before 4.2.3 — fixed in 3.6.12, 4.1.8, 4.2.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 3.6.12, 4.1.8, 4.2.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/5qs207krzg51jl3zs3cvnl5lt9njp8c3
- http://www.openwall.com/lists/oss-security/2026/08/06/17
Get alerted when CVE-2026-65432 or the next vulnerability affects your stack