What’s Vulnerable › Vulnerabilities
CVE-2026-65589: n8n before 1.123.64 Credential Exposure via LLM Node Execution Data
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-29
- Weakness: CWE-532
Description
n8n versions before 1.123.64 fail to properly mask custom HTTP header credentials in LLM sub-node execution data, writing plaintext API keys and secrets to workflow execution records. Authenticated users with access to execution data can read exposed header values and credentials that persist in the database and can be exported.
Affected products
- n8n-io n8n: before 1.123.64; from 2.0.0 before 2.29.8; 2.30.0 (and their updates) — fixed in 1.123.64, 2.29.8
- n8n-io n8n: before 1.123.64 — fixed in 1.123.64
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.64, 2.29.8; n8n-io n8n 1.123.64. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-89gh-3pgc-v5h2
- https://www.vulncheck.com/advisories/n8n-before-credential-exposure-via-llm-node-execution-data
Get alerted when CVE-2026-65589 or the next vulnerability affects your stack