What’s Vulnerable › Vulnerabilities
CVE-2026-65591: n8n before 1.123.64 Sanitizer Bypass Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-29
- Weakness: CWE-917
Description
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.
Affected products
- n8n-io n8n: before 1.123.64; from 2.0.0 before 2.29.8; 2.30.0 (and their updates) — fixed in 1.123.64, 2.29.8
- n8n-io n8n: before 1.123.64 — fixed in 1.123.64
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.64, 2.29.8; n8n-io n8n 1.123.64. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-pm35-fqvh-cq5g
- https://www.vulncheck.com/advisories/n8n-before-sanitizer-bypass-remote-code-execution
Get alerted when CVE-2026-65591 or the next vulnerability affects your stack