What’s Vulnerable › Vulnerabilities
CVE-2026-65596: n8n before 1.123.64 Credential Exfiltration via GraphQL Node
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-29
- Weakness: CWE-863
Description
n8n before 1.123.64, 2.29.8, and 2.30.1 fails to enforce the "Allowed HTTP Request Domains" restriction on HTTP-based credentials (Header Auth, Basic Auth, Query Auth, OAuth) in the GraphQL node, unlike the HTTP Request node. An authenticated user able to create or edit workflows can point the node's endpoint at a server they control and exfiltrate restricted credentials. Only instances where a credential has "Allowed HTTP Request Domains" configured and is usable by non-owner users are affected.
Affected products
- n8n-io n8n: before 1.123.64; from 2.0.0 before 2.29.8; 2.30.0 (and their updates) — fixed in 1.123.64, 2.29.8
- n8n-io n8n: before 1.123.64 — fixed in 1.123.64
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.64, 2.29.8; n8n-io n8n 1.123.64. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-gq66-9cw5-j5jm
- https://www.vulncheck.com/advisories/n8n-before-credential-exfiltration-via-graphql-node
Get alerted when CVE-2026-65596 or the next vulnerability affects your stack