What’s Vulnerable › Vulnerabilities
CVE-2026-65597: n8n before 1.123.64 DOM-Based XSS via Unsandboxed iframe
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-29
- Weakness: CWE-79
Description
n8n before 1.123.64, 2.x before 2.29.8, and before 2.30.1 contains a DOM-based cross-site scripting vulnerability in the HTML preview, which renders execution output into an iframe srcdoc without the sandbox attribute. A sanitizer bypass allows injected script to execute same-origin as the editor. When a victim opens the preview, the script can call authenticated APIs using the victim's session. An account with global:member privileges can exploit the issue.
Affected products
- n8n-io n8n: before 1.123.64; from 2.0.0 before 2.29.8; 2.30.0 (and their updates) — fixed in 1.123.64, 2.29.8
- n8n-io n8n: before 1.123.64 — fixed in 1.123.64
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.64, 2.29.8; n8n-io n8n 1.123.64. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-p3rg-hrf9-w9gj
- https://www.vulncheck.com/advisories/n8n-before-dom-based-xss-via-unsandboxed-iframe
Get alerted when CVE-2026-65597 or the next vulnerability affects your stack