What’s Vulnerable › Vulnerabilities
CVE-2026-65599: n8n before 1.123.64, 2.29.8, and 2.30.1 Credential Exposure via JWT Header
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-29
- Weakness: CWE-312
Description
n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a credential exposure vulnerability: when configured with a Google Service Account key, the full PEM private key was mistakenly placed in the JWT header's kid field (intended only for a key identifier). Because JWT headers are Base64-encoded rather than encrypted, the private key could be recovered by anything that logged or inspected the JWT. An attacker who obtained the key could impersonate the service account and access or modify any Google Cloud resource it was authorized to use. Only instances using Google Service Account credentials are affected.
Affected products
- n8n-io n8n: before 1.123.64; from 2.0.0 before 2.29.8; 2.30.0 (and their updates) — fixed in 1.123.64, 2.29.8
- n8n-io n8n: before 1.123.64 — fixed in 1.123.64
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.64, 2.29.8; n8n-io n8n 1.123.64. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-9r8p-h6cc-6qhm
- https://www.vulncheck.com/advisories/n8n-before-credential-exposure-via-jwt-header
Get alerted when CVE-2026-65599 or the next vulnerability affects your stack