What’s Vulnerable › Vulnerabilities
CVE-2026-65606: SiYuan before v3.7.2 Cross-Site Scripting to RCE
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-09-17
- Weakness: CWE-79
Description
SiYuan before v3.7.2 contains a cross-site scripting vulnerability in the siyuan:// protocol handler. When a siyuan://plugins/<name> link references a name that is not an installed plugin, the application opens a custom tab and inserts the link's icon parameter into the tab header via innerHTML without escaping it (app/src/layout/Tab.ts), allowing injection of an <img onerror=...> element. Because the SiYuan Desktop renderer runs with nodeIntegration:true, the injected JavaScript can access Node's require and call require('child_process').execSync(...), escalating the cross-site scripting into arbitrary operating-system command execution.
Affected products
- siyuan-note siyuan: before 3.7.2 — fixed in 3.7.2
How to fix
Upgrade to a fixed version: siyuan-note siyuan 3.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/siyuan-note/siyuan/commit/41f2861c87575ff5ac4b50a0520b1a4fe55b4a70
- https://github.com/siyuan-note/siyuan/security/advisories/GHSA-wp64-x7qh-h728
- https://www.vulncheck.com/advisories/siyuan-before-cross-site-scripting-to-rce
- https://github.com/siyuan-note/siyuan/security/advisories/GHSA-wp64-x7qh-h728
Get alerted when CVE-2026-65606 or the next vulnerability affects your stack