What’s Vulnerable › Vulnerabilities
CVE-2026-65608: Grav before 2.0.9 Remote Code Execution via FlexDirectory
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-10-24
- Weakness: CWE-470
Description
Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@: directives by calling call_user_func_array() on attacker-influenced input, validating only that the target is callable (is_callable()) without restricting dangerous functions such as exec, system, passthru, or shell_exec. Because FlexDirectory registers this handler for every Flex directory, it bypasses the validation added to Blueprint::dynamicData() in 2.0.7 (GHSA-fj2p-qj2f-74v5). Any authenticated user with create or update permission on any Flex-based directory (Flex Users, Flex Pages, Flex Objects, or custom Flex types) can execute arbitrary shell commands on the server.
Affected products
- getgrav grav: from 1.7.0 before 2.0.9 — fixed in 2.0.9
How to fix
Upgrade to a fixed version: getgrav grav 2.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/fae9e1bf2c40ce0b50d0dfce647aaa1d22f98969
- https://github.com/getgrav/grav/security/advisories/GHSA-c4wf-2xxc-68qm
- https://www.vulncheck.com/advisories/grav-before-remote-code-execution-via-flexdirectory
- https://github.com/getgrav/grav/security/advisories/GHSA-c4wf-2xxc-68qm
Get alerted when CVE-2026-65608 or the next vulnerability affects your stack