What’s Vulnerable › Vulnerabilities
CVE-2026-65635: Boruta dynamic client registration allows creation of over-privileged OAuth clients
- Severity: high (CVSS 8.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-653
Description
Improper Isolation or Compartmentalization vulnerability in malach-it boruta (Elixir.Boruta.Openid module) allows attackers to register OpenID Connect clients with administrative privileges through the dynamic client registration entry point. Boruta.Openid.register_client/3 forwards caller-supplied registration parameters to the administrative client creation path without a public/admin field-level allowlist, so an unauthenticated registrant can set security-sensitive attributes including supported grant types, authorized scopes, PKCE enforcement, public refresh and revocation behavior, token lifetimes, and signing settings. The library does not distinguish between metadata a public registrant is allowed to set and administrative controls that should require operator approval. This vulnerability is associated with program files lib/boruta/openid.ex and program routines 'Elixir.Boruta.Openid':register_client/3, 'Elixir.Boruta.Openid':parse_registration_params/2. This issue affects boruta from 2.3.0 before 2.3.7.
Affected products
- malach-it boruta: from 2.3.0 before 2.3.7 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: malach-it boruta 2.3.7. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-65635.html
- https://github.com/malach-it/boruta_auth/commit/82584c854a332482232fd25301ab12a835f9f643
- https://github.com/malach-it/boruta_auth/commit/95619a1beaff68fa766cca9b388e7c780d182525
- https://github.com/malach-it/boruta_auth/security/advisories/GHSA-w869-fcf2-68vp
- https://osv.dev/vulnerability/EEF-CVE-2026-65635
- https://github.com/malach-it/boruta_auth/security/advisories/GHSA-w869-fcf2-68vp
Get alerted when CVE-2026-65635 or the next vulnerability affects your stack