What’s Vulnerable › Vulnerabilities
CVE-2026-65637: Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-08-27
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
Affected products
- Apache Tomcat: from 9.0.115 before 9.0.121; from 10.1.53 before 10.1.58; from 11.0.20 before 11.0.25 — fixed in 10.1.58, 11.0.25, 9.0.121
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.58, 11.0.25, 9.0.121. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-65637 or the next vulnerability affects your stack