What’s Vulnerable › Vulnerabilities
CVE-2026-65640
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-09-03
- Weakness: CWE-434
Description
WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author level user or higher. Prerequisites: * Imagick and Ghostscript in use on the server * A malicious user with the `upload_files` capability This issue affects all versions of WordPress. Version 7.0.4 has been released, containing a fix for the vulnerability, and as a courtesy to users on older branches the fix has been backported to all branches back to 4.7.
Affected products
- WordPress: before 7.0.4 — fixed in 7.0.4
How to fix
Upgrade to a fixed version: WordPress 7.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-65640 or the next vulnerability affects your stack