What’s Vulnerable › Vulnerabilities
CVE-2026-6567: Incorrect Authorization in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-14
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.8 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with reporter role to access restricted CI artifact report content they were not authorized to, due to missing authorization checks.
Affected products
- GitLab: from 13.8.0 before 19.2.8; from 19.3.0 before 19.3.5; from 19.4.0 before 19.4.2 — fixed in 19.2.8, 19.3.5, 19.4.2
How to fix
Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/597328
- https://hackerone.com/reports/3603015
Get alerted when CVE-2026-6567 or the next vulnerability affects your stack