What’s Vulnerable › Vulnerabilities
CVE-2026-6575: PostgreSQL pg_restore_attribute_stats accepts values that cause query planning to read past end of stats array
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer over-read in PostgreSQL function pg_restore_attribute_stats() accepts array values of unmatched length, which causes query planning to read past end of one array. This allows a table maintainer to infer memory values past that array end. Within major version 18, minor versions before PostgreSQL 18.4 are affected. Versions before PostgreSQL 18 are unaffected.
Affected products
- PostgreSQL: from 18.0 before 18.4 — fixed in 18.4
How to fix
Upgrade to a fixed version: PostgreSQL 18.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6575 or the next vulnerability affects your stack