What’s Vulnerable › Vulnerabilities
CVE-2026-65895: Grav API Plugin before 1.0.10 Broken Access Control
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-10-24
- Weakness: CWE-862
Description
Grav API Plugin versions before 1.0.10 fail to restrict write access to security-critical plugin configuration scopes, allowing authenticated users with api.config.write privilege to modify rate limiting and CORS settings. Attackers can disable rate limiting site-wide to enable credential brute-forcing attacks and reconfigure CORS policies to include attacker-controlled origins with credentials enabled.
Affected products
- getgrav grav: before 1.0.10 — fixed in 1.0.10
How to fix
Upgrade to a fixed version: getgrav grav 1.0.10. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav-plugin-api/commit/f9438d4e71389b1041ac60b69b0b5714ecfa3bdd
- https://github.com/getgrav/grav/security/advisories/GHSA-4pqv-2qj5-38fp
- https://www.vulncheck.com/advisories/grav-api-plugin-before-broken-access-control
- https://github.com/getgrav/grav/security/advisories/GHSA-4pqv-2qj5-38fp
Get alerted when CVE-2026-65895 or the next vulnerability affects your stack