What’s Vulnerable › Vulnerabilities
CVE-2026-65896: Grav API Plugin before 1.0.10 Path Traversal via move
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-10-24
- Weakness: CWE-73
Description
Grav API Plugin (Composer package getgrav/grav-plugin-api) before 1.0.10 fails to properly validate the slug field in the POST /pages/{route}/move endpoint. PagesController::move() sanitizes the slug only with ltrim($body['slug'], '.'), which strips leading periods but does not neutralize '/' or '..' segments. An authenticated API caller with the api.pages.write permission can supply path traversal sequences (e.g., 01.home/../../../pwned) to move an entire page directory (content and media) to an arbitrary writable location outside user/pages/, including outside the Grav installation.
Affected products
- getgrav grav: before 1.0.10 — fixed in 1.0.10
How to fix
Upgrade to a fixed version: getgrav grav 1.0.10. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav-plugin-api/commit/f9438d4e71389b1041ac60b69b0b5714ecfa3bdd
- https://github.com/getgrav/grav/security/advisories/GHSA-qjq4-jp55-4mx2
- https://www.vulncheck.com/advisories/grav-api-plugin-before-path-traversal-via-move
- https://github.com/getgrav/grav/security/advisories/GHSA-qjq4-jp55-4mx2
Get alerted when CVE-2026-65896 or the next vulnerability affects your stack