What’s Vulnerable › Vulnerabilities
CVE-2026-65948: Apache Ranger: UnixAuth lacks brute-force protection
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-307
Description
UnixAuth lacks brute-force protection in Apache Ranger versions <= 2.8.0. Note: UnixAuth is NOT a recommended option for production deployments. Users are recommended to upgrade to version 2.9.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Ranger: before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ranger 2.9.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/cx53rbkxkn5hbvzv8ohwvndzrxhc06qf
- http://www.openwall.com/lists/oss-security/2026/08/09/11
Get alerted when CVE-2026-65948 or the next vulnerability affects your stack