What’s Vulnerable › Vulnerabilities
CVE-2026-66001: Frappe: Improper Authorization in OAuth2 Consent Endpoint
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-26
- Weakness: CWE-352
Description
Frappe is a full-stack web application framework. Prior to 15.114.0 and 16.26.0, the approve and authorize functions in frappe/integrations/oauth2.py allow the OAuth2 consent flow to proceed without restricting approve to POST, without a csrf_token in frappe/templates/includes/oauth_confirmation.html, and without scoping an active OAuth token check to the requesting client. An attacker can cause an authenticated user to approve an OAuth grant or reuse authorization state for the wrong client, exposing data and permitting actions within the granted scopes. This issue is fixed in versions 15.114.0 and 16.26.0.
Affected products
- frappe: before 15.114.0; from 16.0.0-beta.1, < 16.26.0
References
- https://github.com/frappe/frappe/commit/336c7d335db762b494acdfe43aea69d459fd51d7
- https://github.com/frappe/frappe/commit/d7460769f999c68d3121b680119f8724ddd3eb9d
- https://github.com/frappe/frappe/commit/eb9c1446cac13236c6d573b136786db2e46254fa
- https://github.com/frappe/frappe/pull/40073
- https://github.com/frappe/frappe/pull/40700
- https://github.com/frappe/frappe/pull/40701
- https://github.com/frappe/frappe/releases/tag/v15.114.0
- https://github.com/frappe/frappe/releases/tag/v16.26.0
- https://github.com/frappe/frappe/security/advisories/GHSA-2ph8-x773-8p2x
Get alerted when CVE-2026-66001 or the next vulnerability affects your stack