What’s Vulnerable › Vulnerabilities
CVE-2026-66008: Parse Server 9.0.0 Information Disclosure via GraphQL Error Messages
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-209
Description
Parse Server versions >= 9.0.0 before 9.10.0-alpha.6 and >= 8.2.2 before 8.6.87 disclose Pointer and Relation target class names through GraphQL validation and input-coercion error messages when public schema introspection is disabled (graphQLPublicIntrospection: false, the default). Because these errors are produced before authentication, authorization, or any resolver runs, an unauthenticated client possessing only the public application ID can trigger errors on Pointer or Relation fields to reconstruct hidden schema class names, partially defeating the schema-hiding protection. Only schema metadata (class names) is exposed; no object data, credentials, or user records are disclosed.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.0-alpha.6; from 8.2.2 before 8.6.87 — fixed in 8.6.87, 9.10.0-alpha.6
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.87, 9.10.0-alpha.6. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-r2g6-4f6j-f6rf
- https://www.vulncheck.com/advisories/parse-server-information-disclosure-via-graphql-error-messages
Get alerted when CVE-2026-66008 or the next vulnerability affects your stack