What’s Vulnerable › Vulnerabilities

CVE-2026-66009: Parse Server 9.0.0 Information Disclosure via GraphQL Error Messages

Description

Parse Server versions >= 9.0.0 before 9.10.0-alpha.5 and >= 8.2.2 before 8.6.86 return GraphQL validation error messages that name required custom input fields even when public introspection is disabled (graphQLPublicIntrospection: false, the default). A client holding only the public application id — with no user session, master key, or maintenance key — can trigger validation errors to learn the names of required (non-null) custom fields on classes it already references by name, partially defeating the schema-hiding intent of disabling public introspection. No stored data, credentials, optional field names, unreferenced class names, or Cloud Code function names are exposed.

Affected products

How to fix

Upgrade to a fixed version: parse-community parse-server 8.6.86, 9.10.0-alpha.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-66009 or the next vulnerability affects your stack