What’s Vulnerable › Vulnerabilities
CVE-2026-66011: ImageMagick before 7.1.2-27 Memory Leak via Invalid CLI Options
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-25 · updated 2026-08-04
- Weakness: CWE-401
Description
ImageMagick before 7.1.2-27 contains a memory leak vulnerability in the magick command-line interface when invalid options are provided. Attackers can trigger memory exhaustion by repeatedly supplying malformed command-line arguments to consume system resources.
Affected products
- ImageMagick: before 7.1.2-27 — fixed in 7.1.2-27
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-27. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-cvhv-g4rq-3hmw
- https://www.vulncheck.com/advisories/imagemagick-before-27-memory-leak-via-invalid-cli-options
Get alerted when CVE-2026-66011 or the next vulnerability affects your stack