What’s Vulnerable › Vulnerabilities
CVE-2026-66013: OpenRemote before 1.26.2 Authentication Bypass via Console Registration
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-25 · updated 2026-07-30
- Weakness: CWE-639
Description
OpenRemote before 1.26.2 contains an authentication bypass vulnerability in the console registration API that allows unauthenticated attackers to update existing console assets by supplying a known asset identifier. Attackers can overwrite push notification tokens and console metadata without authentication or ownership validation, redirecting notifications or denying delivery to legitimate consoles.
Affected products
- openremote: before 1.26.2 — fixed in 1.26.2
How to fix
Upgrade to a fixed version: openremote 1.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/openremote/openremote/security/advisories/GHSA-gpfc-h59v-63cv
- https://www.vulncheck.com/advisories/openremote-before-authentication-bypass-via-console-registration
- https://github.com/openremote/openremote/security/advisories/GHSA-gpfc-h59v-63cv
Get alerted when CVE-2026-66013 or the next vulnerability affects your stack