What’s Vulnerable › Vulnerabilities
CVE-2026-66142: Apache Neethi: Uncontrolled recursion in policy processing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-400
Description
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
Affected products
- Apache Software Foundation Apache Neethi: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Neethi 3.2.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/fomwtwt4pzzhxn4fyn3skykto913vfzt
- http://www.openwall.com/lists/oss-security/2026/07/24/8
Get alerted when CVE-2026-66142 or the next vulnerability affects your stack