What’s Vulnerable › Vulnerabilities
CVE-2026-66144: Apache Neethi: Remote PolicyReference fetch lacks resource bounds
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-400
Description
Although remote policy references are not retrieved during policy normalization, if they are manually retrieved via the API it can cause a denial of service attack if a huge policy is retrieved. Users are recommended to upgrade to version 3.2.3, which fixes this issue by imposing a default maximum size on data read from remote policy references.
Affected products
- Apache Software Foundation Apache Neethi: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Neethi 3.2.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/80xwwbhkqvbwkkmco6yl6fr5xkpdysjf
- http://www.openwall.com/lists/oss-security/2026/07/24/10
Get alerted when CVE-2026-66144 or the next vulnerability affects your stack