What’s Vulnerable › Vulnerabilities
CVE-2026-66362: NGF vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-76
Description
Description: When NGINX Plus is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the Authentication Filter Custom Resource Definition clientID or cookieName fields, or in the clientSecret field of a Secret referenced by an Authentication Filter, are rendered directly into NGINX configuration templates without sanitization or escaping. Impact: An authenticated attacker with permission to create or modify these resources may craft values that inject arbitrary NGINX configuration directives. This is a control plane issue; there is no data plane exposure.
Affected products
- F5 NGINX Gateway Fabric: from 2.5.0 before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-66362 or the next vulnerability affects your stack