What’s Vulnerable › Vulnerabilities
CVE-2026-6638: PostgreSQL REFRESH PUBLICATION allows SQL injection via table name
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection in PostgreSQL logical replication ALTER SUBSCRIPTION ... REFRESH PUBLICATION allows a subscriber table creator to execute arbitrary SQL with the subscription's publication-side credentials. The attack takes effect at the next REFRESH PUBLICATION. Within major versions 16, 17, and 18, minor versions before PostgreSQL 18.4, 17.10, and 16.14 are affected. Versions before PostgreSQL 16 are unaffected.
Affected products
- PostgreSQL: from 16.0 before 16.14; from 17.0 before 17.10; from 18.0 before 18.4 — fixed in 16.14, 17.10, 18.4
How to fix
Upgrade to a fixed version: PostgreSQL 16.14, 17.10, 18.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6638 or the next vulnerability affects your stack