What’s Vulnerable › Vulnerabilities

CVE-2026-66391: Apache Wicket: leaked and missing CSP headers

Description

Use of Insufficiently Random Values, Protection Mechanism Failure vulnerability in Apache Wicket. This issue affects Apache Wicket: from 9.0.0 through 9.23.0, from 10.0.0 through 10.9.0. Users are recommended to upgrade to version 10.10.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Wicket 10.10.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-66391 or the next vulnerability affects your stack