What’s Vulnerable › Vulnerabilities
CVE-2026-66393: NLTK before 3.9.4 Denial of Service via JSONTaggedDecoder
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-22 · updated 2026-10-14
- Weakness: CWE-674
Description
NLTK versions before 3.9.4 contain an unbounded recursion vulnerability in JSONTaggedDecoder.decode_obj() that allows attackers to cause denial of service by supplying deeply nested JSON structures. Attackers can craft JSON payloads exceeding the recursion limit to trigger an unhandled RecursionError that crashes the Python process.
Affected products
- nltk: before 3.9.4 — fixed in 3.9.4
How to fix
Upgrade to a fixed version: nltk 3.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-rf74-v2fm-23pw
- https://www.vulncheck.com/advisories/nltk-before-denial-of-service-via-jsontaggeddecoder
- https://github.com/nltk/nltk/security/advisories/GHSA-rf74-v2fm-23pw
Get alerted when CVE-2026-66393 or the next vulnerability affects your stack