What’s Vulnerable › Vulnerabilities
CVE-2026-66397: phpMyFAQ before 4.1.6 Path Traversal via category image deletion
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-10-24
- Weakness: CWE-22
Description
phpMyFAQ before 4.1.6 fails to validate path traversal sequences in the existing_image field during category updates, allowing authenticated attackers to delete arbitrary files by exploiting insufficient sanitization in Image::delete(). Attackers can delete the database.php configuration file to disable the installation gate and access the public setup wizard to create new superadmin accounts.
Affected products
- thorsten phpMyFAQ: before 4.1.6 — fixed in 4.1.6
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-mh9w-5hr8-3272
- https://www.vulncheck.com/advisories/phpmyfaq-before-path-traversal-via-category-image-deletion
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-mh9w-5hr8-3272
Get alerted when CVE-2026-66397 or the next vulnerability affects your stack