What’s Vulnerable › Vulnerabilities
CVE-2026-66400: Grav Login Plugin before 3.8.13 Insufficient Session Expiration
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-10-23
- Weakness: CWE-613
Description
Grav Login Plugin versions before 3.8.13 contain an insufficient session expiration vulnerability in TokenStorage.php where the findTriplet() method fails to properly validate Remember Me token timestamps. Attackers with a captured Remember Me cookie can authenticate indefinitely instead of the configured timeout period, as the expiry check compares an array to a scalar value which always evaluates incorrectly in PHP.
Affected products
- getgrav grav: before 3.8.13 — fixed in 3.8.13
How to fix
Upgrade to a fixed version: getgrav grav 3.8.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-mj78-8gwc-vxjj
- https://www.vulncheck.com/advisories/grav-login-plugin-before-insufficient-session-expiration
- https://github.com/getgrav/grav/security/advisories/GHSA-mj78-8gwc-vxjj
Get alerted when CVE-2026-66400 or the next vulnerability affects your stack